당황스런 "지원되지 않는 하드웨어" 메시지당황스런 "지원되지 않는 하드웨어" 메시지

Posted at 2017.07.29 19:46 | Posted in Software


이번에 컴퓨터를 새로 장만하였다. 정말 좋은 제품, 고심 끝에 제품을 고르고 윈도우를 설치하였는데 이게 뭐지? 지원되지 않는 하드웨어라니!!



잽싸게 구글링을 해보니 카비레이크(Kaby Lake)를 사용하는 CPU의 경우 윈도우7에서 업데이트를 막아놓았다는 사실을 알게 되었다. 일단 저 문구도 잘못되었는것이 "보안 업데이트를 놓칠 수 있다는 가능성"을 언급한 것이 아니라 걍 보안 업데이트를 막은 것이다.


그리고 월별 품질롤업을 삭제하면 된다고 나와있어 블로그에서 알려준 업데이트로 번호로 찾아봤는데 또 없다. 아마 기존에 사용하고 있던 사용자가 3월이 되면서 월별 품질롤업의 영향을 받은 것으로 생각된다.



무거운건 제일 싫어하기때문에 고사양의 가벼운 윈도우를 위해 방법을 찾아보았더니 역시나 외국분이 CPU 체크를 우회할 수 있는 프로그램을 공개하였다!!


https://github.com/zeffy/wufuc/


해당 프로그램을 설치하고 나서 지원되지 않는 하드웨어 메시지를 나오지 않고 있으며, 윈도우 업데이트도 잘 된다!!

Name __

Password __

Link (Your Website)

Comment

SECRET | 비밀글로 남기기

Notepad++ 어플에서 파이썬 이용하기Notepad++ 어플에서 파이썬 이용하기

Posted at 2014.08.21 21:25 | Posted in Software

파이썬 언어로 개발하기 위해 선택하는 IDE로 PyCharm을 많이 사용하지만 용량이 크고 성능이 낮은 컴퓨터에서는 느린 실행 속도가 문제이다. 무거운 도구 말고 가벼운 도구가 있을까 찾아보다가 Notepad++ 어플에서 파이썬을 실행하는 방법을 알았다. 이 방법을 공유하고자 한다.

 

파이썬은 인코딩 문제가 많은데 내가 편집하고 있는 파일이 UTF-8 인코딩을 사용하여야 한다. UTF-8 (BOM 없음) 옵션이 기본인데 이것을 그냥 UTF-8 로 선택한다.

 

 

편집 화면에서 자동 완성 기능을 이용하려면 환경 설정 > 백업/자동 완성 탭에서 각 입력에 자동완성 사용을 선택한다. 참고로 Notepad++ 최신 버전을 사용하면 함수 및 단어 모두 자동 완성 기능을 사용할 수 있다. 그 아래에 있는 입력시 함수 인자 정보 보이기 도 선택하여 프로그래밍을 할 때 도움을 받을 수 있다.

 

 

Notepad++ 어플에는 외부 커맨드와 현재 실행시키고 있는 파일을 연동하여 어떠한 행동을 할 수 있게 지원해주는 플러그인이 있는데 NppExec 라는 플러그인이다.

 

Plugin Manager 다이어로그로 이동하여 NppExec를 선택하고 설치를 하면 플러그인이 설치가 되고 직접 플러그인 파일을 받아 Notepad++ 어플의 플러그인 폴더에 압축을 해제해주어도 된다.

 

 

이제 단축키 몇 개를 알아야 하는데 F6 단축키를 이용하면 현재 내가 편집중인 문서와 외부 명령어를 연결할 수 있도록 설정해주는 메뉴가 출력된다. 환경 변수 $(FULL_CURRENT_PATH) 는 Notepad++ 어플에서 사용하는 환경 변수로 현재 내가 결고 있는 문서의 경로를 포함한 이름을 가진다. 파이썬 명령어가 이 파일을 선택하도록 설정한다.

 

 

설정이 끝나면 Ctrl + F6 단축키를 이용하여 현재 내가 열고 있는 파일을 인터프리터 할 수 있다.

  1. 비밀댓글입니다

Name __

Password __

Link (Your Website)

Comment

SECRET | 비밀글로 남기기

파이썬용 오라클 라이브러리와 오라클 버전 차이 문제파이썬용 오라클 라이브러리와 오라클 버전 차이 문제

Posted at 2014.08.21 18:07 | Posted in Software

 

파이썬을 빠른 시간동안 쉽게 이해하기 위해 프로젝트를 진행하기로 하였다. 프로젝트에 필요한 Functional Requirement 산출하고 이를 바탕으로 모듈을 분리하였다.

 

이제 오라클 라이브러리를 사용하여 오라클 데이터베이스에 접근을 시도하고자 하였다. 그런데 오류가 발생하였다. "ORA-24315: 속성 유형이 부적당합니다" 라는 오류 메시지가 출력되었다.

 

구글 검색을 하여도 무슨 오류인지 모르고 있다가 순간적으로 떠오른 것이 내가 다운로드해서 설치한 라이브러리의 버전이 맞지 않을 것이라는 생각이 들었다.

 

그래서 내가 접근을 하고자 하는 오라클 데이터베이스 서버의 버전을 확인하였더니 설치한 라이브러리보다 한 단계 낮은 버전이었다. 라이브러리를 다시 다운을 받고 설치하여 실행하였더니 정상적으로 실행되었다.

 

 

Name __

Password __

Link (Your Website)

Comment

SECRET | 비밀글로 남기기