파이썬용 오라클 라이브러리와 오라클 버전 차이 문제파이썬용 오라클 라이브러리와 오라클 버전 차이 문제

Posted at 2014.08.21 18:07 | Posted in Software

 

파이썬을 빠른 시간동안 쉽게 이해하기 위해 프로젝트를 진행하기로 하였다. 프로젝트에 필요한 Functional Requirement 산출하고 이를 바탕으로 모듈을 분리하였다.

 

이제 오라클 라이브러리를 사용하여 오라클 데이터베이스에 접근을 시도하고자 하였다. 그런데 오류가 발생하였다. "ORA-24315: 속성 유형이 부적당합니다" 라는 오류 메시지가 출력되었다.

 

구글 검색을 하여도 무슨 오류인지 모르고 있다가 순간적으로 떠오른 것이 내가 다운로드해서 설치한 라이브러리의 버전이 맞지 않을 것이라는 생각이 들었다.

 

그래서 내가 접근을 하고자 하는 오라클 데이터베이스 서버의 버전을 확인하였더니 설치한 라이브러리보다 한 단계 낮은 버전이었다. 라이브러리를 다시 다운을 받고 설치하여 실행하였더니 정상적으로 실행되었다.

 

 

Name __

Password __

Link (Your Website)

Comment

SECRET | 비밀글로 남기기